AN1369
KYI@ APPLICATION NOTE

GETTING STARTED WITH RAISONANCE IDE
FOR THE ST6 MICROCONTROLLER

by Microcontroller Division Applications

INTRODUCTION

Ride is the development toolchain for ST62 developed by Raisonance. This fully Integrated
Development Environment supports all the ST62 microcontroller family and features a pow-
erful macro-assembler, a linker, a C compiler and a state-of-the-art simulator and debugger. It
can drive the ST6-HDS2, CEIBO EB-ST62 and SOFTEC DS6225A & DS6265A emulators.
You can install the evaluation version from either the “MCU ON CD” CD-ROM or directly from
the Raisonance website: http://www.raisonance.com.

This tutorial has been extracted from the User Manual of the ST6 Evaluation Board, ST6-Eval,
available on either the “MCU ON CD” CD-ROM or on the ST MCU website http://mcu.st.com.

For more information about Raisonance IDE, please contact Raisonance at http://www.rai-
sonance.com and to get other program examples, please refer to the ST6 Evaluation Board
Manual.

Note: The corresponding source files are provided in a downloadable .ZIP file along with this
note on the ST MCU website http://mcu.st.com

The goal of this application note is to help you get started with the Raisonance IDE environ-
ment using an example program tutorial.st6 located in the directory .\Exercises\Tutorial.
The exercise will make you familiar with the project management, the assembler syntax and
debugging using the Raisonance IDE.

The aim of the tutorial.st6 program is to make two LEDs blink at a frequency of 1Hz, simply
using the 1/O Ports. It assumes that the LEDs are connected to port PAO and PA1 of the
ST6265C device and are active low.
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

1 PROJECT SETUP

1. Start the Raisonance IDE: from the Windows Start menu, select Start > Programs > Rai-
sonance Kit 6.1> Ride IDE.

2.Now you need to create a new project environment. The project file stores all the parame-
ters of the project: settings, options, and all the files that have to be included to the project.
To create a new project, go to the Project menu and click on New. The dialog box shown in
Figure 1 will appear.

Figure 1. New project dialog box

~@* New Project BE

M arne: In::"ae:-:Ern:ises'\tutnrial"»tuturial.|:|ri

Directony: b stutonialy

Type: 5TE j

Cancel Browise Help |

3.Click on Browse to find the path where you want to create your project and name it (e.g.
tutorial.prj). Click on the OK button to validate the creation of the project.

4.Now you have a new window (Project >Debugger) with the name of your new project.
Click on it with the right mouse button. A menu shown in Figure 2 will be displayed.

4
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

Figure 2. New Project Menu

Praoject ]Dehugge,i ;1 This prograu make
;| approximately fre
C:AEXERCISES

Debug Start/Stop

Hode properties

Target options

Tool Dptions k
Debug Optionz

Link,
Make
Build

Wiew Listing

Add Group

Add node Sourcesdpplication Alt+lns

Delete File Alt+Del

5.Click on Add node Source/Application (or find it in the Project menu) to add the file you
want to work on. Choose the tutorial.st6 assembly file located int the .\Exercises\Tutorial.
When you select this file, it will display the file code and you will also be able to see it in the
project window as shown below.

Figure 3. Project tree

x|

Praject I Debuggeri
. —_——————————mS—_—S —_

6.You HAVE TO specify the target option before compiling any program. This defines the
microcontroller used to run the program. Click on the Options > Target menu and choose
the microcontroler you are working with (the ST6265C in this case). Click OK to validate the
selection.

4
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

Figure 4. Type of project dialog box

Type of project |
— Type:

Addrezs 0= |0ES kaszk Ox)13

—Toolzsmode———— ~ DRER
[V Caze senzitive {

— Microcontroller
Hser BOM Size [3872  bytes

5T62E50 =]
STE2E2C = Uszer A&k Size I'I 24 butes
STEZB3C =
STE280B =
STE285B bl
(] I Cancel | Help |

Now the project environment is set up and you can start playing with the code.

2 EDITING THE CODE
You can now start correcting the file! You will have to fill in the blanks next to the question
marks.

Before you start work, here is a brief explanation of the toolbar.

Figure 5. Editing toolbar

|e? 5 EE 2

(]| | Dul g ful | lu]}

|o KAEY v, |

|

This is a list of the actions invoked by each toolbar icon from left to right:

— Open a file in the editor
Note: Be aware that this only opens a file. It doesn’t open a project (to do that you have to se-
lect Project > Open) and it doesn’t add the file to the project automatically (to do that you have
to select Project > Add node Source/application).

— Save the changes you made to your file

— Tile the windows vertically

— Enter Debug mode

— Compile (Translate) the single file that is activated or the one that is selected in the Project

View window.
— Compile (Make all) all the files of the project (recommended)
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

—Undo command

— Cut command

— Copy command

— Paste command

—Find an expression in the file

— Find the Next same expression

3 COMPILING THE CODE

A good way to get familiar with RIDE is to start compiling your program before making any cor-
rections and, then, to correct the errors little by little.

1. Click on the Make all icon to compile the assembly file.

A new window will now appear like that shown in Figure 6. This window shows you the
errors and the warnings the compiler generated and displays the results of the compilation.

Figure 6. Errors and warnings in the Make window

Make Il:lebug I Grep I Seript I

HI Funning MASTE on c:\exercizes\tutorialstutarial st6
o = ERROR #1580 IM LINE 65 OF tutonial.zt6 - UMENDWM MEEMOMNIC

------ 4 “*ERROR #1501M LIME BB OF tutonal sth : UNENOWMN MNEMONIC

2.Double-click on the warning or error messages to see the line of the program related to the
message. The corresponding line in the program window will be highlighted.

3. Start correcting the errors. Once you have finished, you can save your changes by clicking
on the Save icon or on the menu File >Save. Compile the file again until you made the right
corrections, that is to say when no error messages appear anymore. Figure 7 shows the
window you will get at this point.
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

Figure 7. Successful Make window

Make IDebug i Grep I Script I

2 Running M&STE on c:\exercises\tutarialstutanial =16
----- Funning BLSTE on c:\exercizeshtutonaltutanial. aof
& Funning the tool C:5\Pragram FileshBIDEABinsohstEw32.dll [HEX] on c:\exerciz:

x|

4 STARTING A DEBUG SESSION

In the last section the only thing we did was to compile, i.e. to make sure the program had the
right syntax and the right structure.

We now have to check if it really does what we want it to do. This is the debug phase. This will
be done by using the Raisonance simulator to simulate the behaviour of the microcontroller.

1.Click on the Debug icon to enter debug mode.
The following dialog box will appear:
Figure 8. Debug options dialog box

~@* Debug Dptions

— Tool
: i aF.
& Virtual Machine [Simulator)
" Real Machine [Emulator or BOM-onitor) Cancel
™ Otker Tool
Help
—Device [See OptionzT aiGet] 1 Frequency-
Advanced Optionz
[siM-sTE = | Crustal iMHZ] [2000
STARTERKIT-STE

When you click on Options > Debug you can select the type of debug you want to do. Select
Virtual Machine (Simulator) then SIM-ST6 and click on the OK button.
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

Figure 9. Simulator Environment

~m:RIDE - c:\exercises\tutorial\tutorial. pri - [c:\exercises\tutorial\tutorial. st6]
[, Fle Edit Search Project Tool View Debug Options RideScript Window Help -18]x|

[ || [ iy v
[ 8 E B b o ol ] G0 e | o |

1di DDRA, 03h ; are low =

Praject  Debugger |

e e [} reti ; Exit the WNT mode
- cerercisesutanalutorial aot
B MAIN ROUTINE
3| mam: 14 ¥, COUNTER ; Load X with the COUNTER value(d cycles)
4 LOOPL: 14 4, OFFm ; Init the acrumulstor to OFFh (4 cycles)
4 LOOPZ: dec A ; Decrement & (4 cycles)
3 jraz LO0PZ : fump to LOOPZ wtil & reaches zero (2 cycles)
s dec X ; Decrement X (4 cycles)
» jraz LOOPL : fump to LOOPL wntil X reaches zero (2 cycles)
Intenupt cantroller
Special Pins G TOGGLE: jrr 0, DRA, LEDOFF ; Test the current LEDs status (5 cycles)
PA 2 1di DR&, 00h ; If OFF, turn them 0N {4 cycles)
FB 2 ip MATH ; dump to MATH (4 cycles)
PC
Tirmer #| LEDOFF: 14 DRA, 03h ; If OM, turn thew OFF (4 cycles)
Ato Reload Timer 2 i MATN ; dump to MAIN (4 cycles)
watch Dog i MumCycles = 4 + {4+ (4 + 2) * 255+ 4+ 2) * COUNTER + 5 + 4 + 4
AD convertsr ; Delay = (NumCycles = OSC_DIV % 13) / fose = 1 seconde
EEPROM
SPI
;1 RESTART AND INTERRUPT VECTORS l
CSEG at  OFFh : Define the mddress vhere the interrupt vectors

: #4, #3, #2 and #1 are be mapped

? reti

# reti

» reti

# reti

CSEG at  OFFCh : Define the address vhere the interrupt vectors
: #0 end reset are be mapped

4 VEC_IT NMI: nop

s reti

5T: ip INIT ; Jump to the res sub-routine

END PROGRAM =

Maks  Debug IGlep ] geripr |

# Opening o erercissshtutonalutorial. aof
+ Opens file chenercisesutarialitutarial aot

+ Frequency: 5000000 MHz

+ OMF-STE Module cihenercises\utorialiutarial acf has been successiully loaded.

[ | T 000 ms.0ps O s | 1050 [N5 [NUM [CaPS
In this environment you have several tools to help you to simulate and view what the program
does.

Let’s have a look at the Debug toolbar:

Figure 10. Debug Toolbar

ol g"' ﬂ"' tutorial :_’J GO e

Here is a list of the actions invoked by the toolbar icons from left to right:
— Enable Animated Mode

— Display executed lines. Each line containing an instruction in the program is indicated with
a green dot. If you press this icon, the green dot next to the executed line becomes blue.

— Refresh command.
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

— Reset command. This button corresponds exactly to a hardware RESET.
— Execute each line and each function routine step by step (step into).

— Execute each line step by step (step over).

— Add the watch window.

— Add a toggle breakpoint at the selected line of the program. Click again to disable the
breakpoint.

—Add atoggle trace at the selected line of the program. Click again to disable the toggle trace.
— Select the file you want to debug.

— Run the application. If Animated Mode is selected, it runs the application at a set speed that
can be selected with the next icon. Otherwise it runs the application in real-time.

— Set the execution speed of the application in Animated Mode.

4.1 STEPPING THROUGH THE CODE

Execute the program step by step using the step over icon. Each time you click on this icon
you will see the current line changing to the next program instruction. At each step you are
then able to look at the state of the microcontroller, as explained later on.

Note: The step into icon allows you to enter the function subroutines. It is not likely that you
will need this feature at the beginning. Furthermore this is a rather tedious way of following the
execution of the program, because you really step through all the functions.

4.2 RUNNING THE CODE
You can also run the program directly using the Run icon.

Click once on the icon: it will run the application and the icon will change to

ﬁ

Click on the icon again and the application is stopped.

Note at the bottom of the Debug window the period of time spent running the application.

T: 0:0:200 ms. 731 ps. 375 ns

4
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

4.3 SETTING A BREAKPOINT
Restart the program by selecting the Debug >Restart menu.

Click on the vertical bar on the left side of the program window in front of the line where you
want to place the breakpoint. The line will be highlighted in red and the next time you run the
application, the program counter (PC) will stop at the breakpoint.

Figure 11. Set breakpoint

@ dec = Al
# jrnz LOOPL Fodu
NGGLE: jrr 0, DEL, LEDOFF ;

@ 1di DEL, 00k L
2 ip MATH SRR
# LEDOFF 144 DREL . N3k + Tf

To delete the breakpoint simply click on the red S sign again.

4.4 WATCHING A VARIABLE

Click on Debug >Add Watch. A dialog box will appear: it allows you to select the registers, la-
bels or variables you want to watch from a list of expressions. Type PA.0 and click on the OK
button.

Figure 12. Add watch dialog box

~@*Watch EE3
E spression: ||:~,.-_~.'_|:| j
1] Cancel Help |

4
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

Then the following window will appear. It stores all the expressions you need.

Figure 13. Watch window

B Watch [tutorial) =]

M ame Walue

Now click with the right button of your mouse on the Watch Window and select Add. This
opens the Add Watch Dialog Box again. Type PA.1 and click on the OK button.

Figure 14. Watch window

B Watch [tutorial]  [E[=]

M ame W alue
FA.0O TERUTE

4
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

4.5 VIEWING THE PERIPHERALS OR THE ST6 REGISTERS
In the Debugger window you can see all the microcontroller’s registers and peripherals.

Figure 15. Debugger window

x|

Project  Debugger I

EI% c:hesercizeshtutonalstutanal. aof

(= %@e [Data dump
. Fw# Disassembly cods
s Code Yiew
T Data View
s Stack Yiew
LwE Bit View
...... e Main registers

H!%D Peripherals
------ Intermpt cantroller

------ Special Pinz

...... =1y

...... FE

...... PC

...... Tirmer

------ Auto Beload Timer
------ Yiatch Diog

------ A0 corverter

...... EEPROM

...... SR

Double-click on any of the items and you will be able to view their state at any time during de-
bugging. Figure 16 shows the window that will be displayed when you double-click on the PA

icon.
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

Figure 16. Port A window

1 PA [tutorial]  [E[=] 3

0 F Mo Connection

DDHIDD [ Mo Connection
DR {00 [ Mo Connection

ORj00 [ Mo Cannection
=[] [Nn:u Connection

E Mo Cannection

[ Mo Connection
7 E Mo Connection

Figure 17 shows the window that will be displayed when you double-click on the Main Regis-
ters icon.

Figure 17. Main registers window

@ Main Registers [tutorial)

—CFU —DATA

PC  [oFFE 4 oo

DRWER (00 =CODE[0000] b |E||:|

PRPR Joo | DRBA o0 | v oo

(|| W |00 w oo
Co elfo Fenfo I8 pe|rr
2l Z0 2ol G

To watch the values of certain registers only, the address of the labels or the value of the pos-
sible variables, you have to open the Watch Window.

4.6 TIME FEATURE

If you want to determine the time spent for one or several instructions of your program, set
breakpoints at the first and last instruction. Run your program with the Run icon. It will stop at
the first breakpoint. Then select the Debug > Reset Time menu (you can also use the macro
Ctrl + T). The displayed time is reset. If you click on the Run icon again, it will display the time
spent executing the instructions.
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

4.7 ADVANCED FEATURES
4.7.1 Trace window

An easy way to see how the program is executed is to trace the state of the PAO and PAl
ports. You should be able to see the value toggling from 1 to 0 and 0 to 1 every 0.5s.

Keep the Watch Window open, select PA.O and click on the right mouse button. The following
menu will appear:

Figure 18. Add/Delete from Trace List

B Watch [tutorial) _ O]

Mame |, Yalue

PA.1 TEUE Evaluate
Format
Add [nzert
Delete Suppr
Delete all

Select the Add/Delete from Trace List item and a blue “T” will be displayed in front of PA.O.
This will allow you to watch the trace of the PAO pin (you can do the same for PA1) in the Trace
Window.

Figure 19. PAO and PA1 Toggle Trace

B Watch [tutonal] =]
M arne |_‘-Ialue

DPA.0 TRUE

Then select the View >Trace >Options menu to set the Trace Options dialog box. Then click
on the On Changes radio button. The trace will be updated each time the value of the se-
lected item is changed.
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

You can also change the maximum number of records that can be displayed in the Trace

window. Validate the choice with the OK button.

Figure 20. Trace Options dialog box

@ Trace

Trace | Wign I

Extended Mades

~ Mode:
o ™ Continual ™ Flazhing
@ OnChanges ¢ Toogling £ Evtended

b aximum number of recards:
¥ Raolling trace
" | Tirace orlysaurze lirnes

[T Reset trace list before run

P

[~ Record list in a text file

File: |

ok Cancel

Click now on the View >Trace >View menu to open the trace window.

4
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

Figure 21. Trace window

' Trace [tutorial] M =] B4
:00:00.006/0:00:00.123 50: 080 SUE A, 4 TRIE
s00:00,1300:00:00,052 30:08E LDT ORA, 3 FALZE FAL:
s00:00,1820:00: 502,27 530:091 LDI count, TERUE TR
:IEIEI:EEIE.-ilE Q:00: 502,27 50: 0408 LDT count, FALSJE Fflll
1 b
Fa
Fa.0
1 1 1 1 1 1
0:00:500.000 00100000 201500000 00200000 002500000 0030

4.7.2 Refresh feature

Now insert a refresh tag so the window will be refreshed each time the instruction, where it is
placed, is processed. Place it at the program line where the “TOGGLE" label is located so that
the trace will be regenerated at each commutation of the pin.

To do this, click on the source code line containing the "TOGGLE" label (so that the cursor
blinks), and click on the left margin with the right mouse button. The following menu on the
next page appears.

4
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

Figure 22. Left margin menu

# TOGGLE: jr Open document  Cil+Shift+0 he current LEDs status
j :!'ﬂ Go ko Line Crl+5 I; ﬁ;ﬁ 1;1;&1]':1 ETE;? ETed
T yiew Code Chl+Shift+C ]
#| LEDOFF: 14 AddWatch F& turn them OFF (4 cycl
@ ip Evaluatekodify  Chl+hd o MAIN (4 cycles)
; MumCycles = Indent + 2) * COUNTER + &5 + 4
! Delay = (Num |nzpect Clrl+l 8c = 1 seconde
e e M =55 o s e
Run to cursor Chrl+0)
Set PC to cursor - Chrl+S hift+0)
Toggle Flag... Toggle breakpoint F2 |-
2 FESTART AT Toggle trace F4
Tooggle refresh F2 [1_
CSE at OFFOh e i : =
4a. # Toagleswich Eil i
s VEC IT 1 nop : : Tongletigger El0

Select Toggle Flag >Toggle refresh and a small light bulb icon will appear in front of the line
as follows:

Figure 23. Toggle refresh mark

EERY

%W TOGGLE : jrr 0, DEA, LEDOFF ; Tezst the current LED=s
@ 1di DE4, 0O0h ; If OFF, turn them 0N
@ ip MaATH ; Jump to MATN (4 cycle

At this point, you may want to resize the windows in the screen to have a clear view if what
happens when you run the application. You can use the Tile Vertical icon for example. Now,
click on the Run icon and watch the program working! Figure 24 on the next page shows an
example of the debug screen you can have.

4
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

Figure 24. Debug overview

~m:RIDE - c:\exercises\tutorial\tutorial. pri
File Edt Search Project Tool Wiew Debug Options RideScript Window Help

[_[=]]

B By [ I3 ARE
e | | [ Y
a¥as + + + i .

Bl E B G b ot o ol [

X 5 Code [tutorial) =13 I
Eilec Dmggyl i ) [pddress [Symbol |Code |Mnemanic |
- o herercisesutonahutoral aof 2 sty ARl e T mode WF_o6 LOOFL: 141 A, OFFh ; Init the accula]

- Data dump g 093: LOOFL 17FF LDI A, OFF
i Disassembly cods ##_67 LOOPZ: dec A ; Decrement & {4 cyc
MATH ROUTINE 095: Loopz FFFF DEC &
3| MATN: 1ai ¥, COUNTER ; Load X with the COUNTER walue(d cycles) ‘#—_EE JniE . Lo0Ae cidubn tosL00RZ ity
3 LOOPL: 1ai &, OFFh ; Init the accumilator to OFFh (4 cycles) pleie £ LRIl A
Bt View B s 5 #4_69 dec X ; Decrement X (4 cycles)
) Main egisters s 3 J og8: E
£ 420 Peripherals 2 dec X ; Decrement X (4 cycles) e T Jou ke RRER. D DG wenl
AL Intemnupt controller s jrnz  LOOPL ; Jump to LOOPL wntil X reaches zero (2 cycles) 3;9;2 ——— C]fm LEDDFJHZ_;USU:;E
Special Ping = o & £ .
@ TOGGLE: jrr 0, DRA, LEDOFF ; Test the current LEDs status (5 cycles) B2 EEGELE SRk Rt
e » 1di  DRA, 00h ; If OFF, tumn them ON (4 cycles) ;%:’3 L DRE S DnhDDED’DDIf DFL‘;)'I E;‘;; "Dhe“
el L (7 (LT ip  MATH ; Jump to MAIN (4 o3
Timer = 0an: 0308 JF MAIN
Auto Reload Timer [ Watch (tutorial] =l EX ##_76 LEDOFF: 1di DRA, 03h  ; Tf ON, turn
‘Watch Dog Source : L] Name | Vel paz: LEDOFF 0DC003 T pRa, 3 x|
AD converter :04:04.5850:01: 01, 110/30: 045 JP MAIN  TRUE TRIE ﬁl @EA.0 TALSE Seach:| |
EEPROM $05:05.5950:01:01. 110/50: 040 JP MAIN | FALSE FALSE @pa.1 |razes
- TSR T T Cu— T o _'ﬂ o BIobal Sybols Toatonall o]
»
| Name | Space | Address | vawe |
I Data FF 0xEF -
Bl ADCR Data Dl 00
Pal £ 4R Data i 00
Bl ARCP Data D 0x0
B ARIR  Data DE 00
q & apmc Data D5 o0x0 =
BAD £l 4FRC Data D3 0x0
- - y " Bl ARSCO Data D& 00
0:05:00.000 0:07:500.000 0:10:00.000 0:12:500.00C B apscl Data o7 0x0
ElDDEA  Data 4 023
4 PA [tutorial]  [E]ER| |5 Main Registers [tutorial] EEE || ¢ Timer [tutarial) 3 | R Data Cs 00
— EIDDEC  Data s 0x0
o | Mo Connection CFU DATA TR [FF T [V Data co 0xFC
DOR|03 | [ INo Connection FC [oos7 & [eF @ H ore beta oL FRFF
DR|00 [ Mo Connection DRwWR [00 | -CODEmN00) % [57 | i DRER Data Eg 0x0 r
oR[o3 TSCR [o0 vl ara o b
. [ Mo Connection PRFR [00 | DRER [0 v lﬁ DRl DAL L% [EE.
L [ Ma Connection e Resien
i " v [00] w oo Counter inhibited F Code -
Ma Connection ¥ Dat B
Frescaler Division Faclar: 1. [ Data
[ Mo Comecton e I O Y Timer Operating Modes IV Stack
7 [ No Connestion 2o | 2o | 2o ||| ool ] Event Counter Mode I Bit
< | o
Make  Debug |5mp ] soript |
# Frequency: 8.000000 MHz =
+ OMF-5TE Module c-\exercisesMutorialutorial aof has been successiuly loaded
+ [T:000ms0psOnsk Fun
4+ [T 013745 ms. 294 ps.500nsk  Stop

i -

[ [ T:0:13:147 ms 270 ps 500 nis [ EB14 N5 [NUM [CAFS

4.7.3 Animate Mode

Finally, you can run the program using Animated Mode. This mode allows you to see the pro-
gram execute at a desired speed. To do this, click on the Animated Mode icon and then click
on the Run icon. You should be able to see the PC running through the program. To set the
speed faster or slower, use the speed slider, and drag the index to the desired position on the
scale.
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

4.7.4 Disassembly code window

You can open the Disassembly code window by selecting the corresponding icon in the
Project > Debugger window.

Figure 25. Disassembly code window

l&ddreas J|5ymhn| J|C:|:u:|e ]|ru1nem|:|nic J|I:
g5 T jrnz loop ;s Jump to loop | |

## 79 inc count ; Elze count=count+l (4 cycles) |
09D TFa4d INC count p
## a0 1d A, count P A=count (4 cycles) |

09F: 1Fs4 LI A4, count ‘
## 0l cpi A, COUNTER ; If A'=COUNTER (4 cycles)

O&al: 3757 CPI &, 57 ‘
## 02 Jjrnz tempo ; dJump to tempo (2 cycles) |

DAZ: =11 JENZ tempo p
## 94 toggle: Jjrr 0, DRA, ledoff ; If LEDs actiwvesz => turn 'off’
Oad: toggle 03Co0s JEE 0, DRL, ledoff {
## 80 1di DEA, 0O0h ! Turn 'on' the LED= (4 cycles)

OA7: oDCcooo LDI DRL, O ]
## o7 clr count ! Clear count (4 cycles)

Oad: oLa400 LDI count, O ]

You can then check the code at each address of the program memory area. Each line of the
program is displayed with its address, the label if applicable (Symbol), the op-code actually
executed (Mnemonic), and the number of times the PC executed the line.

4
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GETTING STARTED WITH RAISONANCE IDE FOR THE ST6 MICROCONTROLLER

4.7.5 External interrupt window

You get the Interrupt Controller window after selecting the corresponding icon in the Project
- Debugger window.

Figure 26. Interrupt controller window

+ Interrupt controller [tutorial)

Each Interrupt can be individually enabled

FFCH NMI : Interrupt is ENABLED, Priority = 1

FF6H PA: Interrupt is DISABLED, Priority = NONE

FF6H PB : Interrupt is DISABLED, Priority = NONE

FFAH PC : Interrupt is DISABLED, Priority = NONE

FFOH Owverflow Timer : Interrupt is DISABLED, Priority = NONE
FFZH AR-Timer : Interrupt is DISABLED, Priority = NONE

FFOH AD Converter : Interrupt is DISABLED, Priority = NONE
FFAH SPI: Interrupt is DISABLED, Priority = NONE

I0R=10

This window enables you to check whether each interrupt is enabled or not.

Now it's up to you if you want to make changes to the program (e.g. change the value of
COUNTER to modify the delay) or to test the different features of RIDE.

To exit debug mode and return to edit mode, select the Debug >Terminate menu.
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5 ENABLING AST6/LST6 RIDE COMPATIBILITY

RIDE is able to process AST6/LST6 files. If you want to use them, select Options >Project
and the following dialog box will appear.

Figure 27. Project options dialog box

Options:

EE rvironment:
i Directories
-RCSTR
-MASTE
-ALSTE

E3R EA L

ok Defaultz | LCancel | Help |

Then, double-click on MAST6 > source and check the Use AST6 syntax check box: as
shown on the next page.
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Figure 28. Project options dialog box

Options:
- Erviranment ¥ Define symbals for the STE function registers
Directaries oo ms e s e .
E-RCSTR ¥ Use ASTE Syntart
- MASTE
¢ i Sounce

- Set

ok Defaultz | Cancel | Help |

This option allows you to assemble files written for the STMicroelectronics AST6 assembler

and LST6 linker. A preprocessor will automatically be called to translate the AST6-like direc-
tives in MA-ST6-like directives.
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“THE PRESENT NOTE WHICH IS FOR GUIDANCE ONLY AIMS AT PROVIDING CUSTOMERS WITH INFORMATION
REGARDING THEIR PRODUCTS IN ORDER FOR THEM TO SAVE TIME. AS A RESULT, STMICROELECTRONICS
SHALL NOT BE HELD LIABLE FOR ANY DIRECT, INDIRECT OR CONSEQUENTIAL DAMAGES WITH RESPECT TO
ANY CLAIMS ARISING FROM THE CONTENT OF SUCH A NOTE AND/OR THE USE MADE BY CUSTOMERS OF
THE INFORMATION CONTAINED HEREIN IN CONNEXION WITH THEIR PRODUCTS.”

Information furnished is believed to be accurate and reliable. However, STMicroelectronics assumes no responsibility for the consequences
of use of such information nor for any infringement of patents or other rights of third parties which may result from its use. No license is granted
by implication or otherwise under any patent or patent rights of STMicroelectronics. Specifications mentioned in this publication are subject
to change without notice. This publication supersedes and replaces all information previously supplied. STMicroelectronics products are not
authorized for use as critical components in life support devices or systems without the express written approval of STMicroelectronics.
The ST logo is a registered trademark of STMicroelectronics
[J2001 STMicroelectronics - All Rights Reserved.

Purchase of I2C Components by STMicroelectronics conveys a license under the Philips I12C Patent. Rights to use these components in an
12C system is granted provided that the system conforms to the I1°C Standard Specification as defined by Philips.

STMicroelectronics Group of Companies
Australia - Brazil - China - Finland - France - Germany - Hong Kong - India - Italy - Japan - Malaysia - Malta - Morocco - Singapore - Spain
Sweden - Switzerland - United Kingdom - U.S.A.

http://www.st.com
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